Вопросы с тегом 'npm-install'

npm install - это команда в npm CLI, которая ищет и устанавливает указанный пакет из репозитория npm.
15

Как установить пакет npm из GitHub напрямую?

Попытка установить модули из github приводит к: Ошибка ENOENT на package.json. Легко воспроизводится с помощью выражения: npm install https://github.com/visionmedia/express выдает ошибку. npm install express работает. Почему я не могу устано...
07 июл. '13 в 5:55
16

xcode-select активная ошибка каталога разработчика

Увидел следующую ошибку при запуске npm install которая требовала " node-gyp... но могла быть вызвана чем-либо, что требует xcode-select. xcode-select: error: инструмент 'xcodebuild' требует Xcode, но активный каталог разработчика '/Library/Develo...
31 июл. '13 в 20:52
11

Почему "npm install" переписывает package-lock.json?

Недавно я обновился до npm @5. Теперь у меня есть файл package-lock.json со всем пакетом package.json. Я ожидал бы, что, когда я запустил npm install, чтобы версии зависимостей вытащили из файла блокировки, чтобы определить, что должно быть установл...
10 июл. '17 в 21:38
17

Невозможно установить NodeJs:/usr/bin/env: node: нет такого файла или каталога

Я пытаюсь установить nodeJs в свой Ubuntu 14.04, чтобы использовать GruntJs. Я читал о Ubuntu другим способом (проблемы?), так что это что я сделал для его установки: sudo apt-get install npm sudo npm install -g grunt-cli Набрав grunt после этог...
12 окт. '14 в 1:17
3

Установка локального модуля с использованием npm?

У меня загруженный модуль repo, я хочу установить его локально, а не глобально в другой каталог? Что такое простой способ сделать это?
11 нояб. '11 в 1:53
8

Как обновить TypeScript до последней версии с помощью npm?

В настоящее время на моем компьютере установлена версия TypeScript 1.0.3.0. Я хочу обновить его до последней версии, то есть 2.0. Как это сделать с помощью npm?
24 сент. '16 в 14:27
26

npm ERR! код ELIFECYCLE

Я пытаюсь научиться реагировать, поэтому у меня есть этот образец кода для полнофункционального приложения для голосования, и я пытаюсь заставить его работать, но после запуска установки npm после запуска npm я получаю следующую ошибку: npm ERR! Dar...
17 февр. '17 в 23:02
7

Как решить npm UNEPT PEER DEPENDENCY

Я нахожусь в Windows 10, Node версии 5.6.0 и Npm версии 3.6.0. Попытка установить angular -материал и mdi в рабочую папку. npm install angular -material mdi предоставляет следующие сообщения об ошибках: + - angular @1.5.0 + - НЕЗАВИСИМАЯ НЕЗАВИС...
02 мар. '16 в 4:09
3

В чем разница между "npm install" и "npm ci"?

Я работаю с непрерывной интеграцией и обнаружил команду npm ci. Я не могу понять, каковы преимущества использования этой команды для моего рабочего процесса. Это быстрее? Это делает тест более сложным, хорошо, и после?
25 сент. '18 в 13:38
20

Ошибка установки NPM: неожиданный конец ввода JSON при разборе рядом с "... nt-webpack-plugin": "0"

При создании нового проекта Angular 5: версия узла: 8.9.2 версия npm: 5.5.1 Моя команда npm install -g @angular/cli Ошибка нпм ERR! Неожиданный конец ввода JSON при разборе рядом с '... nt-webpack-plugin ":" 0 " нпм ERR! Полный журнал этого п...
06 дек. '17 в 13:26
5

npm установить и построить разветвленную github repo

Это не совсем новый вопрос, но сейчас я хорошо смотрю, и у меня проблемы с поиском решения. Я использую модуль для моего приложения angular, называемого angular -translate. Тем не менее, мне пришлось внести несколько небольших изменений в исходный ...
10 нояб. '16 в 12:49
5

Установите конкретную ветку из github, используя Npm

Я хотел бы установить bootstrap-loader из github в моем проекте, используя npm В настоящее время они поддерживают две версии этого проекта, которые совместимы с webpack версии 1 и 2. Я хотел бы установить версию 1. Какую команду npm я должен исполь...
27 сент. '16 в 19:00
24

npm - EPERM: операция не разрешена в Windows

Я побежал npm config set prefix /usr/local После выполнения этой команды, При попытке запуска любых команд npm в ОС Windows я продолжаю получать ниже. Error: EPERM: operation not permitted, mkdir 'C:\Program Files (x86)\Git\local' at Error (nativ...
04 янв. '16 в 22:21
4

Как установить grunt и как с ним построить script

Привет, Я пытаюсь установить Grunt на Windows 7 64 бит. Я установил Grunt с помощью команд npm install -g grunt npm install -g grunt-cli но теперь, если я пытаюсь сделать grunt init, это вызывает у меня ошибку - Не удалось найти действительн...
29 мар. '13 в 12:50
4

Нужно ли мне как package-lock.json, так и package.json?

После обновления моего NPM до последней версии (от 3.X до 5.2.0) и запуска npm install в существующем проекте, я получаю автоматически созданный package-lock.json. Я могу сказать, что package-lock.json дает мне точное дерево зависимостей, а не pack...
12 июл. '17 в 8:35