Вопросы с тегом 'mysql2'

Драгоценный камень Mysql2 предназначен для чрезвычайно распространенного случая подключения, запроса и повторения результатов.
28

Ошибка при установке mysql2: Не удалось создать собственное расширение gem

У меня возникают проблемы при установке mysql2 gem для Rails. Когда я пытаюсь установить его, запустив bundle install или gem install mysql2, он вызывает следующую ошибку: Ошибка при установке mysql2: ERROR: Не удалось создать собственное расширен...
31 авг. '10 в 10:54
8

Rails 4 - Gem:: LoadError: указанный "mysql2" для адаптера базы данных, но драгоценный камень не загружен

В моем gemfile я: gem 'mysql2' My database.yml выглядит следующим образом: default: &default adapter: mysql2 database: <%= ENV['db_name'] %> username: <%= ENV['db_user'] %> password: <%= ENV['db_pass'] %> host: ...
08 сент. '15 в 12:18
13

Gem:: LoadError для gem mysql2, но он уже находится в Gemfile

Gem::LoadError Specified 'mysql2' for database adapter, but the gem is not loaded. Add `gem 'mysql2'` to your Gemfile Эта ошибка возникла при загрузке следующих файлов: active_record/base Это ошибка, которую я получаю при запуске сервера rails. ...
08 апр. '14 в 9:00
11

Ruby gem mysql2 install failing

Когда я пытаюсь установить gem mysql2, он терпит неудачу без видимых ошибок. Кто-нибудь знает, что делать, чтобы обойти это, чтобы установить mysql2? Tanner-Smiths-MacBook-Pro:Humans_vs_Zombies_Parse tanner$ sudo gem install mysql2Building native e...
06 нояб. '10 в 20:57
8

mysql2 gem, скомпилированный для неправильной клиентской библиотеки mysql

Когда вы пытаетесь подключиться к серверу mysql через мое приложение rails, я получаю следующую ошибку D:/Program_Files/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require': Incorrect MySQL client library version! This gem wa...
05 янв. '12 в 10:22
8

Ошибка при попытке установить приложение с помощью mysql2 gem

Я пытаюсь установить приложение с открытым исходным кодом rails 3.2.21, использующее камень mysql2, но когда я пытаюсь запустить комманду bundle, я получаю следующую ошибку: Fetching: mysql2-0.3.18.gem (100%) Building native extensions. This could...
14 июн. '15 в 20:53
7

ОШИБКА: Не удалось создать собственное расширение gem (mysql2 on rails 3.2.3)

Я пытаюсь установить gem mysql2 с Rails 3.2.3, и он не работает: ★ bundle install Fetching gem metadata from https://rubygems.org/......... Using rake (0.9.2.2) Using i18n (0.6.0) Using multi_json (1.2.0) Using activesupport (3.2.3) Using build...
07 апр. '12 в 3:19
9

ЛЕВЫЙ ВНЕШНИЙ ВСТУПИТЕЛЬ В Rails 4

У меня есть 3 модели: class Student < ActiveRecord::Base has_many :student_enrollments, dependent: :destroy has_many :courses, through: :student_enrollments end class Course < ActiveRecord::Base has_many :student_enrollments, depen...
23 июн. '14 в 5:18
7

Головные боли Mysql 5.6 на Mac OSX

Некоторые из моих коллег и я недавно обновили с MySQL 5.5 до MySQL 5.6 с помощью homebrew на наших компьютерах Mac для тестирования локально, прежде чем обновлять наши серверы. Начиная с этого обновления, мы все время сталкивались с прерывистыми ошиб...
23 июл. '13 в 14:50
3

Создание таблиц и проблем с первичным ключом в Rails

Когда я пытаюсь запустить следующий код в Rails, используя Mysql2 в качестве менеджера баз данных: rake db:migrate Я получаю следующую ошибку: rake aborted! "Mysql2::Error: All parts of a PRIMARY KEY must be NOT NULL:" Почему я получаю эту ош...
12 янв. '14 в 14:01
15

Установите mysql-адаптер gem install activerecord-mysql-adapter '

У меня возникли проблемы с поиском решения этой проблемы. Я получаю сообщение об ошибке: Please install the mysql adapter: 'gem install activerecord-mysql-adapter' /Users/ Andy/.rvm/gems/[email protected]/gems/bundler-1.0.21/lib/bundler/rubyg...
07 мар. '12 в 22:16
9

сервер rails не запускается с mysql2, используя rvm & ruby ​​1.9.2-p0 на OSX 10.6.5

Я получаю следующую ошибку при запуске сервера rails: $ rails server /Users/ssmith/.rvm/gems/ruby-1.9.2-p0/gems/mysql2-0.2.6/lib/mysql2.rb:7:in `require': dlopen(/Users/ssmith/.rvm/gems/ruby-1.9.2-p0/gems/mysql2-0.2.6/lib/mysql2/mysql2.bundle, 9...
22 дек. '10 в 18:26
6

mysql2 gem не скомпилируется с MySQL 5.6.12 на OS X с Homebrew

Я обновил все пакеты, которые я установил с помощью Homebrew. MySQL получил обновление до 5.6.12 (от 5.5.27 или около того): $ mysql --version mysql Ver 14.14 Distrib 5.6.12, for osx10.8 (x86_64) using EditLine wrapper и теперь глагол mysql2 бо...
21 июн. '13 в 14:51
16

Установка Ruby MYSQL2 gem на windows 7

Я пытаюсь установить gem mysql2 в Windows 7, я загрузил соединитель с сайта mysql и поместил libmysql.dll в ruby200\bin затем выполните gem install mysql2 Это результаты, я здесь здесь тусклый? Temporarily enhancing PATH to include DevKit... Build...
25 сент. '13 в 19:58
2

Установите gem mysql2 на Snow Leopard для Rails 3 с rvm

Недавно я обновился до Rails 3 и создал новое приложение с Rails 3.0.3, но продолжаю получать сообщение об ошибке Macintosh:$ rails server => Booting WEBrick => Rails 3.0.3 application starting in development on http://0.0.0.0:3000 => Call...
28 нояб. '10 в 14:36