Вопросы с тегом 'command-line-tool'

Средство командной строки - это консольное приложение, работающее в MS-DOS или в терминале (командная строка для Windows и терминал для Linux и Mac).
16

xcode-select активная ошибка каталога разработчика

Увидел следующую ошибку при запуске npm install которая требовала " node-gyp... но могла быть вызвана чем-либо, что требует xcode-select. xcode-select: error: инструмент 'xcodebuild' требует Xcode, но активный каталог разработчика '/Library/Develo...
31 июл. '13 в 20:52
13

Xcode - установить средства командной строки

Как получить инструменты для построения командной строки, установленные с текущим Xcode/Mac OS X v10.8 (Mountain Lion) или позже? В отличие от Xcode нет установщика (это просто пакет). Похоже, что все инструменты командной строки существуют (в комп...
17 февр. '12 в 13:38
11

Что является более быстрой альтернативой Python http.server(или SimpleHTTPServer)?

Python http.server (или SimpleHTTPServer для Python 2) - отличный способ обслуживать содержимое текущего каталога из командной строки: python -m http.server Однако, что касается веб-серверов, это очень slooooow... Он ведет себя так, как будто он ...
15 окт. '12 в 23:27
10

двоичные файлы клиента svn для окон

Где находятся двоичные файлы Windows для версии SVN в командной строке? Везде, где я ищу, это должно быть какое-то причудливое клиентское программное обеспечение с установщиком. Я работаю на машине, где у меня нет учетной записи администратора. Прос...
05 мар. '09 в 0:23
3

Xcode 6.1 - Как удалить инструменты командной строки?

Я установил инструмент командной строки Xcode, выпустив xcode-select --install; теперь я хочу удалить его (без удаления Xcode). Я пробовал sudo /Developer/Library/uninstall-devtools --mode=all но затем я получаю ошибку sudo: /Developer/Library...
12 дек. '14 в 6:58
6

"pod init" создает ошибку, в которой говорится: "Вам нужно как минимум git версия 1.8.5 использовать CocoaPods"

Я не смог установить ни одного модуля в моей системе. Поэтому я удалил cocoapods из моего Mac, а затем переустановил его. Процесс прошел успешно, но когда я запускаю команду pod init в терминале появляется следующая ошибка: 'verify_minimum_git_versi...
30 июн. '17 в 6:53
8

инструменты командной строки для новых 10.9 OSX для рубиновых драгоценных камней?

После установки демонстрации OSX Mavericks 10.9, я получаю это после запуска пакета Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension. /Users/sandric/.rvm/rubies/ruby-1.9.3-p194/bin/ruby extconf.rb extconf.rb...
12 июн. '13 в 13:30
4

Сообщение об ошибке "Только Xcode недостаточно для Sierra"

Я хотел бы установить openCV для векторизации изображения, но есть сообщение об ошибке серии Xcode и Ruby. Во-первых, я использую терминал для установки openCV, brew install opencv. Затем появилось сообщение об ошибке, указывающее, что системе не ...
23 нояб. '17 в 16:41
10

Как я могу добавить "теги" OS X к файлам программно?

Так как Mavericks, OS X имеет возможность тегировать и окрашивать файлы в Finder. Есть ли способ добавить теги в файлы через API Cocoa или через команду оболочки?
01 нояб. '13 в 3:36
5

Установите gnuplot 5.0.1 на OSX

Я загрузил исходные файлы для gnuplot 5.0.1 (gnuplot-5.0.1.tar.gz) с исходной страницы forge. Я также установил средства командной строки в моей OS X 10.7.5, чтобы у меня есть gcc и make в папке /usr/bin. Я следовал инструкциям по установке, найден...
06 сент. '15 в 8:49
1

Mac OS app, песочница с инструментом командной строки?

Я сделал приложение, которое включает в себя инструмент командной строки. Я включил песочницу приложений и протестировал ее. Я также подписал код как с приложением, так и с инструментом командной строки. Но когда я загружаю приложение в iTunes, я по...
06 авг. '12 в 1:40
9

Файл Pod не инициализируется?

Когда я пытаюсь инициализировать файл pod для использования cocoapods через терминал, он дает мне эту ошибку. Как это исправить. /Library/Ruby/Gems/2.0.0/gems/cocoapods-1.2.0/lib/cocoapods/command.rb:128:in `verify_minimum_git_version!': [!] You ne...
02 февр. '17 в 7:28
5

macOS 10.14 (beta) Как установить Command_Line_Tools_macOS_10.14_for_Xcode_10_Beta

В качестве заголовка моего вопроса я не знаю, как установить Command_Line_Tools_macOS_10.14_for_Xcode_10_Beta для моего mac, пожалуйста, помогите. Что я сделал: запустить команду "brew install carthage", чтобы установить Карфаген, получить ошибки:...
19 июн. '18 в 9:39
1

Наложение двух видео на статическое изображение?

У меня есть два видео, которые я хотел бы объединить в одно видео, в котором оба видео будут сидеть поверх статического фонового изображения. (Подумайте, что-то вроде this.) Мои требования заключаются в том, что используемое мной программное обеспече...
15 нояб. '12 в 2:27
4

Как отлаживать CLI python, который принимает stdin?

Я пытаюсь отлаживать Python CLI, который я написал, который может принимать свои аргументы от stdin. Простой тестовый пример будет иметь выход echo "test" | python mytool.py эквивалентно выходу python mytool.py test Я хотел бы отладить некоторы...
12 июн. '13 в 19:57