Вопросы с тегом 'backport'

Backporting - это действие либо для принятия новой версии программного обеспечения, либо для его распространения в более раннем дистрибутиве, либо с использованием определенной модификации программного обеспечения (patch) и применения его к более старой версии программного обеспечения, чем первоначально было создано.
14

Как вернуться к старой версии нашего кода в Subversion?

Я работаю над проектом с другом, и я хочу вернуться к более старой версии нашего кода и установить его как текущий. Как это сделать? Я использую "anksvn" для vs08. У меня есть версия, которую я хочу на моем ПК, но коммит не работает; Сообщение, кот...
02 мая '09 в 8:35
1

Кто-нибудь еще поддерживал Лямбду-выражения на Java 7?

Читая о какой тип байт-кода Java 8 генерирует из lambdas, мне пришло в голову время, когда была выпущена Java 5. Тогда было Retroweaver и другие инструменты для преобразования байт-кода, скомпилированного с JDK 5, для запуска на JRE 1.4. Кто-нибуд...
19 июл. '13 в 22:41
3

Как я могу использовать код BitmapRegionDecoder в android 2.2.2 (Froyo)?

Я читал ответ на другой вопрос на SO, в котором @RomainGuy прокомментировал, что можно (пожалуйста, поправьте меня, если я перефразирую неправильно) код порта из более поздних версий android для более ранних версий. В частности, меня интересует обрат...
05 апр. '12 в 20:00
11

python 2.7 functools_lru_cache не импортирует, хотя установлен

Когда я пытаюсь импортировать matplotlib, я получаю сообщение об ошибке Traceback (most recent call last): File "<stdin>", line 1, in <module> File "/usr/local/lib/python2.7/dist-packages/matplotlib/__init__.py", line 128, in <mod...
08 нояб. '17 в 12:12
4

Форматирование строк без индекса в python2.6

У меня есть много тысяч строк кода python с форматированием строки стиля python2.7 + (например, без индексов в {} s) "{} {}".format('foo', 'bar') Мне нужно запустить этот код под python2.6, а python2.6 требует индексов. Мне интересно, знает ли кт...
11 дек. '13 в 16:08
3

Использование `@unittest.skipIf` со старыми версиями Python

С модулем unittest мне нравится функция пропускать тесты, но она доступна только в Python 2.7 +. Например, рассмотрим test.py: import unittest try: import proprietary_module except ImportError: proprietary_module = None class TestProprie...
12 июн. '12 в 5:54
2

debugInfoEnabled для Angular 1.2

Angular 1.3 ввел новый метод debugInfoEnabled(), который может обеспечить повышение производительности, если вызвано с помощью false в конфигурации приложения: myApp.config(['$compileProvider', function ($compileProvider) { $compileProvider.deb...
05 янв. '15 в 16:05
1

Доступ к Python enum34 по имени

Я использую backport enum34 с Python 2.7. В соответствии с документацией должно быть возможно получить доступ к членам перечисления по их имени, используя доступ к элементу. То есть должно работать следующее: from enum import Enum class Foo(Enum)...
22 сент. '15 в 14:50
5

Возможности Backport Java 5/6 для Java 1.4?

Мы застряли с Java2SE v1.4 до конца 2010 года. Это действительно противно, но мы не можем это сделать. Какие варианты мы должны использовать некоторые из новых функций уже сейчас? Я могу думать о нескольких способах, таких как изменение байт-кода, ...
18 июн. '09 в 9:24
7

Легкий способ резервного копирования кода Java 6 на Java 5?

Мы разрабатываем приложение на базе Windows с использованием Java на некоторое время, но сейчас мы хотим сделать порт Mac и вынуждены отменить код с Java 6 и Java 5. Есть ли какой-либо простой способ сделать это, чем перекодирование конкретного кода ...
20 авг. '08 в 13:50
2

"Backporting" nullptr для С++ - программы pre-С++ 0x

Более или менее то, что предлагает название. Пока я пока не использую С++ 0x Я хотел бы быть готовым к тому, когда это произойдет, и я также хотел бы уменьшить количество кода я придется переписывать, чтобы использовать некоторые из своих средств. Та...
05 янв. '12 в 17:37
2

Backport Python 3.4 регулярное выражение "fullmatch()" на Python 2

Python 3.4 представил новый метод regex re.fullmatch(pattern, string, flags=0). Кто-нибудь обратил этот новый метод к более старым версиям Python?
13 мая '15 в 10:39
1

Есть ли резервная библиотека Rails 4?

Со временем мы обновляем части нашего приложения Rails 3.2.x, чтобы быть совместимым с Rails 4. Например, любой наш новый код написан с использованием сильных параметров вместо attr_accessible. Мы хотели бы использовать подобный подход для таких фун...
16 янв. '14 в 19:08
1

Есть ли резервный файл python 2 для пакета concurrency.futures из python 3

Я хотел бы использовать хороших исполнителей и API-интерфейсов потоков, но я ограничен средой Python 2. Я не могу перейти на Python 3 из-за другой зависимости от третьей стороны. Самый близкий ответ, который я нашел, - это: Параллельно в Python 2
21 февр. '17 в 20:30
2

Python 2.6 до 2.5 чит-лист

Я написал свой код для установки Python 2.6.5, но теперь мне нужно запустить его в кластере, который имеет только 2.5.4, что не было на горизонте, когда я написал код. Скрыть код до 2.5 не должно быть слишком сложно, но мне было интересно, есть ли чи...
07 окт. '10 в 13:13