Использовать Swift 2.2 в Xcode 8?

Можно ли использовать Swift 2.2 в Xcode 8?

Из примечаний к выпуску Xcode 8:

"Xcode 8 поддерживает коммутацию наборов инструментов, например, из swift.org, без перезапуска Xcode. (23135507)"

Я пытаюсь найти switch 2.2 toolchain на сайте swift.org, но не смог. Имейте хоть один успех в настройке Xcode 8 для работы с быстрым 2.2

+71
источник поделиться
5 ответов

Невозможно использовать Swift2.2 в XCode8, а также невозможно использовать Swift2.3 или Swift3 в XCode3.

Лучшее решение, которое я нашел, - это создать один файл проекта, который будет компилироваться как для iOS 9 (Xcode 7), так и для iOS 10 (Xcode 8) и который будет поддерживать Swift2.2 и Swift2.3 (очень похоже).

+6
источник

Если вы хотите продолжить использование Swift 2 в Xcode 8, используйте Swift 2.3, установив параметр Использовать устаревшую версию Swift Language Version (SWIFT_VERSION = 2.3).

+57
источник

Использование Swift 2.3 в Xcode 8 Что Thing в Swift дает хорошее представление об использовании Swift 2.3 в Xcode 8.

В статье цитируется следующее:

Создайте единый параметр построения, который позволит вам продолжить строительство ваши проекты Swift с версией Swift, которая в основном похожа на синтаксис ваших существующих проектов из Xcode 7: использование Legacy Swift Языковая версия

Просто зайдите в свои настройки сборки проектов и найдите наследие быстро найти правильную настройку сборки, затем переключить настройку на YES, чтобы перейти к Swift 2.3 вместо Swift 3 в Xcode 8.

введите описание изображения здесь

+33
источник

В качестве одного из возможных решений этой проблемы я мог бы предложить установить две версии Xcode (7.3.1 и 8, например) рядом.

Для этого вам необходимо:

  • Загрузите подходящий файл dmg из Загрузка для разработчиков Apple. Используйте поиск, чтобы найти Xcode.
  • Дважды щелкните этот файл, чтобы увидеть знакомое окно "Перетащите, чтобы установить Xcode в папку приложений". Но перетащите это где-нибудь еще на мгновение. Рабочий стол был бы хорош. Переименуйте его в Xcode\number of version\(например, Xcode 7.3.1), а затем перетащите его в папку Applications.

Что это.

+3
источник

Невозможно использовать Swift2.2 в XCode8, установив параметр Использовать устаревшую версию языка Swift в Yes в настройках сборки.

+1
источник

Посмотрите другие вопросы по меткам или Задайте вопрос