Ошибка xcode 8, отклоненная делегатом службы (SBMainWorkspace)

Попытка запустить сборку на симуляторе, и я получаю эту ошибку:

Не удалось выполнить запрос на открытие "com.companyname.appname".

Запрос был отклонен делегатом службы (SBMainWorkspace) для причина: безопасность ( "Права" com.apple.frontboard.debugapplications ", необходимый для запуска приложения для отладки" ).

Этого не было при использовании GM Xcode 8, но вскоре он был запущен, когда я снова загрузил его из магазина приложений Mac. Google не помогает и не форум разработчиков Apple.

Любая помощь или предложения?

+142
источник поделиться
14 ответов

Выход из симулятора и перезапуск исправили это для меня.

+329
источник

Пустой параметр вызывает ошибку

В случае, если кто-то задается вопросом, что подразумевается под "пустыми настройками", которые должны быть сняты, как указано в ответе на марику и в комментарии Винаяка Г.Х. По крайней мере, это и послужило причиной для меня проблемы.

+84
источник

Убедитесь, что вы не проверили какие-либо "пустые настройки" в разделе "Продукт" > "Схема" > "Изменить схему" > "Выполнить" > "Переменные среды". это вызывает вышеупомянутую проблему.

+14
источник

проверьте настройки своей схемы и убедитесь, что все пустые настройки не отмечены.

+13
источник

Единственное, что сработало для меня, было:

Симулятоp > Reset Содержание и настройка

Затем очистите и запустите проект

+13
источник

Я страдаю от этой проблемы пару дней. В основном я пробовал все, что можно найти в Интернете, но ни один из них не был действительно полезен. Я даже переустановил Xcode два раза (Xcode 8.3.2 8E2002, симулятор iOS 10.3 14E269). И, конечно, в моем проекте, схеме и пустых настройках ничего плохого не было. Все кажется нормальным. Наконец, я обнаружил, что лучший способ решить эту проблему - до развертывания приложения в симуляторе, вы должны очистить свой проект (shift + cmd + K), а затем снова запустить (cmd + R). Это решит вашу проблему.

+3
источник

Для меня проблема, похоже, связана с тем, что я слишком поспешный, чтобы удалить некоторые красно-hightighted рамки Pod. Я думал, что они пропали без вести, но ошибка права началась сразу же после того, как я их удалил. Ошибка сохранялась до тех пор, пока я не запустил pod install, чтобы восстановить удаленные рамки Pod.

+2
источник

Настройка сборки> Комбинированная> Связывание> Изменение типа Mach - o - на исполняемый файл

Это сработало для меня, потому что я изменил это на статическое раньше.

+2
источник

повторить симулятор...

Это сработало для меня

+1
источник

Удалить (удалить) приложение из симулятора и запустить его снова. работает для меня.

+1
источник

Я следовал всем остальным предложениям здесь, и для меня это исправило бы, если бы я перезапустил Xcode и симулятор, тогда это сработало бы один раз. После этого проблема снова начнет возникать, пока я не перезапущу.

Что исправило это для меня, так это удалить схему и воссоздать ее.

0
источник

Я получил эту ошибку, когда я использую символ "/" в названии цели. Исправлено после удаления.

0
источник

Xcode 10: Удалить все содержимое на симуляторе> Выйти из Xcode> Снова открыть XCode & Перестройка сработала для меня

0
источник
xcode-select --install

Это сработало для меня.

-2
источник

Посмотрите другие вопросы по меткам или Задайте вопрос