Обновление конфликта версий до 8.4.0

Ошибка

Выполнение не выполнено для задачи: app: processDebugGoogleServices '. пожалуйста исправить конфликт версии либо путем обновления версии плагин google-services (информация о последней версии доступен здесь) или обновить версию com.google.android.gms до 8.3.0.

Я сделал все, что нашел.

  dependencies {
            // This does not break the build when Android Studio is missing the JRebel for Android plugin.
            classpath 'com.zeroturnaround.jrebel.android:jr-android-gradle:1.0.+'
            classpath 'com.android.tools.build:gradle:2.0.0-alpha3'
            classpath 'com.google.gms:google-services:2.0.0-alpha3'

            // NOTE: Do not place your application dependencies here; they belong
            // in the individual module build.gradle files
        }

И в приложении gradle

    compile 'com.google.android.gms:play-services:8.4.0'
+196
источник поделиться
14 ответов

Используйте эти зависимости для проекта build.gradle

dependencies {
    classpath 'com.android.tools.build:gradle:2.0.0-alpha3'
    classpath 'com.google.gms:google-services:2.0.0-alpha3'
}

и поместите это в конец файла build.gradle на уровне приложения (после зависимостей).

apply plugin: 'com.google.gms.google-services'

У меня нет подсказки, почему это заканчивается (а не в начале), решает ошибку.

РЕДАКТИРОВАТЬ 5/1/2016

Хорошо... Поэтому, пытаясь положить конец всем проблемам, с которыми вы, ребята, столкнулись с моим решением

Это мой последний уровень приложения gradle

apply plugin: 'com.android.application'

android {
    compileSdkVersion 23
    buildToolsVersion "23.0.2"

    defaultConfig {
        applicationId "your-app-name"
        minSdkVersion 16
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

repositories {
    jcenter()
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'
    compile 'com.android.support:appcompat-v7:23.1.1'
    compile 'com.google.android.gms:play-services:8.4.0'
    compile 'com.android.support:design:23.1.1'
    compile 'com.mcxiaoke.volley:library:[email protected]'
}

apply plugin: 'com.google.gms.google-services'

и это мой конечный уровень проекта gradle

// Top-level build file where you can add configuration options common to all sub-projects/modules.

buildscript {
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.0.0-alpha3'
        classpath 'com.google.gms:google-services:2.0.0-alpha3'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        jcenter()
    }
}

Сравните это с вашими собственными файлами gradle и добавьте или измените любые значения, отличные от того, что я написал.

+335
источник

В прикладном модуле (build.gradle)

Перемещение:

apply plugin: 'com.google.gms.google-services'

до последней строки решена проблема.

+63
источник
другие ответы

Связанные вопросы


Похожие вопросы

Выполните следующие действия:

  • Поместите в файл build.gradle(Application level gradle) следующее:

    dependencies {
          classpath 'com.android.tools.build:gradle:2.0.0-beta2'
          classpath 'com.google.gms:google-services:2.0.0-beta2'
    }
    

Пожалуйста, проверьте здесь для последней версии, так как это продолжает меняться.

  1. Если вы получите сообщение об ошибке ниже, вам необходимо обновить обертку gradle до последней версии gradle -wrapper.properties. Я использую 2.10.

Плагин слишком стар, обновите его до более поздней версии или установите переменную среды ANDROID_DAILY_OVERRIDE

  1. Поместите следующую строку внизу вашего файла build.gradle(уровень модуля gradle)

    apply plugin: 'com.google.gms.google-services
    
+14
источник

Это похоже на версию 3.0.0 плагина Google Services (и версию 9.0.0 в библиотеке Служб Google Play). Итак, с этим

верхний уровень build.gradle

dependencies {
    classpath 'com.google.gms:google-services:3.0.0'
}

Уровень приложения build.gradle

apply plugin: 'com.google.gms.google-services'

dependencies {
    compile 'com.google.android.gms:play-services:9.0.0
}

Краткое примечание. Если вы обновляете до версии 3.0.0 плагина google-services, убедитесь, что вы обновили свой файл конфигурации, так как он имеет новые поля (пояснил здесь).

Edit (2016-06-20): Пока это компилируется и выполняется, я только заметил, что в журналах сборки он указывает, чтобы поместить плагин в нижней части файла, или по умолчанию (9.0.0) использоваться. Поэтому в ситуации выше это не проблема, так как я использую версию 9.0.0, но это может быть проблематично при обновлении зависимости. Здесь журнал:

google-services plugin could not detect any version for com.google.android.gms or com.google.firebase, default version: 9.0.0 will be used. please apply google-services plugin at the bottom of the build file.

+7
источник

Для меня работает только это:

Верхний уровень.

dependencies {
    classpath 'com.android.tools.build:gradle:2.1.0'
    classpath 'com.google.gms:google-services:3.0.0'
}

Уровень приложения:

dependencies {
    compile 'com.google.android.gms:play-services-gcm:9.0.1'
    compile 'com.google.android.gms:play-services-location:9.0.1'
}

// should be at the bottom
apply plugin: 'com.google.gms.google-services'
+5
источник

найден в официальном примере

в проекте gradle

// Top-level build file where you can add configuration options common to all sub-projects/modules.

buildscript {
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.0.0-alpha9'
        classpath 'com.google.gms:google-services:2.0.0-alpha9'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        jcenter()
    }
}

в приложении gradle

apply plugin: 'com.android.application'

android {
    compileSdkVersion 23
    buildToolsVersion "23.0.2"

    defaultConfig {
        applicationId "com.google.samples.quickstart.signin"
        minSdkVersion 18
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"

        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }

    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }

    packagingOptions {
        exclude 'LICENSE.txt'
    }

    // Resolve dependency differences between app and tests
    configurations.all {
        resolutionStrategy.force 'com.android.support:support-annotations:23.1.1'
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    compile 'com.android.support:appcompat-v7:23.1.1'
    compile 'com.android.support:design:23.1.1'

    // Dependency for Google Sign-In
    compile 'com.google.android.gms:play-services-auth:8.4.0'

    // UiAutomatorTesting
    androidTestCompile 'com.android.support.test:runner:0.4.1'
    androidTestCompile 'com.android.support.test:rules:0.4.1'
    androidTestCompile 'com.android.support.test.uiautomator:uiautomator-v18:2.1.2'
    androidTestCompile 'com.android.support:support-annotations:23.1.1'
}

apply plugin: 'com.google.gms.google-services'
+4
источник

Я обновил приложение build.gradle

dependencies {
....
compile 'com.google.android.gms:play-services-auth:9.0.0'

и приложение build.gradle

  dependencies {
    classpath 'com.android.tools.build:gradle:2.1.0'
    classpath 'com.google.gms:google-services:3.0.0'
}

Работает.

+2
источник

В моем случае я удалил "применить плагин:" com.google.gms.google-services "" от конца gradle.build и его работоспособности.

+2
источник

Важно, чтобы установить Gradle в версию 2.10

fooobar.com/questions/32811/...

+1
источник

Я был серьером... на странице Google есть решение... https://developers.google.com/android/guides/google-services-plugin#introduction

Добавьте зависимости для базовых библиотек, необходимых для служб, которые вы включили. Для этого шага требуется, чтобы плагин apply: `com.google.gms.google-services ' был в конце вашего файла app/build.gradle, чтобы не вводить никаких коллизий зависимостей. Вы можете видеть результат этого шага, запустив. /gradlew: app: dependencies.

+1
источник

Нет смысла в подключении плагина apply: 'com.google.gms.google-services 'до конца build.gradle. Это то же самое, что и не определять его.

Просто удалите эту строку и убедитесь, что применили плагин: 'com.android.application' есть

Использование:

compile 'com.google.android.gms:play-services-gcm:8.4.0'
compile 'com.google.android.gms:play-services:8.4.0'

он скомпилируется.

+1
источник

В проекте gradle

buildscript {
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.google.gms:google-services:2.0.0-alpha6'
    }
}

в приложении/модуле gradle

apply plugin: 'com.google.gms.google-services'
android {
    ...
}

dependencies {
    compile 'com.google.android.gms:play-services-analytics:8.3.0'
}
0
источник

В проекте gradle:

       compileSdkVersion 23

Он работает.

-1
источник

Вот моя инструкция по его исправлению.

  • Изменить использование compile 'com.google.android.gms:play-services-location:8.3.0' в приложении build.gradle
  • Переместите apply plugin: 'com.google.gms.google-services' в конец приложения build.gradle
  • Используйте classpath 'com.google.gms:google-services:2.0.0-alpha3' в проекте build.gradle зависимость
  • Измените использование gradle-2.8 в gradle/wrapper/gradle-wrapper.properties
-3
источник

Посмотрите другие вопросы по меткам или Задайте вопрос