Поддержка Realm для Swift 3.0

Мне было интересно, можно ли использовать Realm с бетами Swift 3.0.

Хотя я вижу каталог RealmSwift-swift3.0 в репо Realm, мне не удается правильно его использовать. Как его установить из источника?

+19
источник поделиться
3 ответа

Вы можете использовать Realm с Swift 3.0, но учтите, что текущая версия по-прежнему абсолютно экспериментальна.

Вы можете клонировать главную ветвь realm-cocoa repo из GitHub.

Или вы можете использовать Карфаген:

github "realm/realm-cocoa.git" "master"

Или, если вы предпочитаете CocoaPods:

pod 'RealmSwift', :git => 'https://github.com/realm/realm-cocoa.git', :branch => 'master'

Если вы используете Carthage, помните, что вы должны вручную добавлять рамки Realm и RealmSwift (игнорировать структуру IBAnimatable):

Project configuration image

На самом деле, у меня есть один из моих проектов с Xcode 8, Swift 3 и Realm, и он отлично работает:)

+19
источник

Начиная с версии 1.1.0 Realm официально совместим с Swift 3.0/Xcode 8.0. См. здесь.

Этот выпуск официально поддерживает Xcode 8, Swift 2.3 и Swift 3.0. Предварительно построенные фреймворки теперь построены с помощью Xcode 7.3.1 и Xcode 8.0.

Здесь выдержка из установочных документов:

Если вы используете Xcode 8, вставьте следующее внизу своего подфайла, при необходимости обновите версию Swift:

post_install do |installer|
  installer.pods_project.targets.each do |target|
    target.build_configurations.each do |config|
      config.build_settings['SWIFT_VERSION'] = '2.3' # or '3.0'
    end
  end
end
+5
источник

Компания Realm выпустила новую версию 1.1.0. Если вы используете Cocoapods, предложите проверить этот PR и установить версию 1.1.0.rc.2, чтобы избежать ошибки компиляции Use Legacy Swift Language Version.

0
источник

Посмотрите другие вопросы по меткам или Задайте вопрос