com.google.android.gms: play-services-measurement-base запрашивается различными другими библиотеками

Я обновил до gradle 4.0.1 и начал получать следующую ошибку

Библиотека com.google.android.gms: play-services-measure-base запрашивается различными другими библиотеками по адресу [[15.0.4,15.0.4]], но разрешается до 15.0.2. Отключите плагин и проверьте дерево зависимостей, используя. /gradlew: app: dependencies.

Мой проект не использует эту зависимость, поэтому я искал ее по всему миру, и она только появляется внутри

строить/промежуточные/ворса кэш/maven.google/COM/Google/Android/GMS/группа-index.xml

как эта линия

<play-services-measurement-base versions="15.0.0,15.0.2"/>

Поэтому я попытался удалить папку сборки и очистить проект, но он восстанавливает его с теми же значениями:/следовательно, ошибка все еще остается

+159
источник поделиться
37 ответов
  • 1
  • 2

Актуальная проблема обсуждается в 23-й майской заметке о выпуске https://developers.google.com/android/guides/releases#may_23_2018

В принципе, вам нужно поднять все библиотеки Play Services и Firebase до их последней версии (которая может отличаться для каждой версии с версии 15). Вы можете использовать https://mvnrepository.com/ для поиска последней версии для каждой библиотеки.

См. Также: https://firebase.google.com/support/release-notes/android#20180523

+161
источник

только для меня:

положите его на дно build.gradle

com.google.gms.googleservices.GoogleServicesPlugin.config.disableVersionCheck = true
+84
источник
другие ответы

Связанные вопросы


Похожие вопросы

Обязательно сохраните зависимостей ваших сервисов Google и зависимостей Firebase от последней версии.

Также проверьте все ваши файлы градиента, уровень модуля и уровень проекта, для всех модулей должна быть только одна общая версия зависимости. Может быть решена путем сохранения этих версий в переменной уровня градиента уровня проекта.

Проверьте версию обновления игровых сервисов Google

Последние сервисы Google Play

Проверьте здесь обновленную версию Firebase

Последние сообщения Firebase

Проверьте здесь обновленную версию Firebase для Android

Firebase Android Последние

+29
источник

Я обновил

implementation 'com.google.android.gms:play-services-analytics:16.0.3'

и это работает для меня

+11
источник

изменение моего build.gradle на следующее работало для меня:

ext {
  googlePlayServicesVersion   = "15.0.1"
}

allprojects {
  repositories {
      mavenLocal()
      maven { url 'http://maven.google.com' }
      jcenter { url "http://jcenter.bintray.com/" }
      google()
      maven {
        // All of React Native (JS, Obj-C sources, Android binaries) is installed from npm
        url "$rootDir/../node_modules/react-native/android"
      }

      configurations.all {
        resolutionStrategy {
            force "com.google.android.gms:play-services-basement:$googlePlayServicesVersion"
            force "com.google.android.gms:play-services-tasks:$googlePlayServicesVersion"
        }
      }
  }
}
+8
источник

В моем случае с использованием последних версий следующих dependencies решена моя проблема:

'com.google.android.gms:play-services-analytics:16.0.1'
'com.google.android.gms:play-services-tagmanager:16.0.1'
+6
источник

Это может произойти, если ваш плагин Android Gradle очень старый, даже если вы используете только одну библиотеку Google! Видимо все библиотеки Google раньше должны были быть точно такой же версии. Теперь они не должны быть такими же, только последние. Когда указывается даже одна библиотека, она вытягивает зависимости, где версии не совпадают, а старый плагин Android Gradle рвет.

Установите более новую версию, например:

buildscript {
    dependencies {
        classpath 'com.android.tools.build:gradle:3.3.2'
    }
}

Вам может потребоваться обновить Gradle, чтобы использовать более новый плагин (он сообщит вам).

+5
источник

Только решение, которое работает для меня (найдено где-то в SOF) (не имеет ссылки):

в верхней главной build.grale

allprojects {

subprojects {
    project.configurations.all {
        resolutionStrategy.eachDependency { details ->
            if (details.requested.group == 'com.google.android.gms'
                    && !details.requested.name.contains('multidex')) {
                details.useVersion "x.y.z"
            }
        }
    }
}
+3
источник

Добавьте в список своих зависимостей. Теперь нужно иметь его для правильной работы всех зависимостей firebase:

implementation 'com.google.firebase:firebase-core:16.0.1'
+3
источник

У меня была такая же проблема

Просто убедитесь, что у вас есть последние версии всех зависимостей. Я использовал текущие версии для ядра Firebase и аутентификации. В более новых версиях исправлены ошибки.

Вы можете получить последние версии здесь: https://firebase.google.com/support/release-notes/android

Использование последней версии на текущий момент времени:

в app/build.gradle:

dependencies {
implementation 'com.google.firebase:firebase-core:16.0.6'
implementation 'com.google.firebase:firebase-auth:16.1.0'
}
+3
источник

Подобная проблема возникла у меня, когда я попытался добавить базу данных Firebase в свой проект.

implementation 'com.google.firebase:firebase-core:16.0.1'
implementation 'com.google.firebase:firebase-database:16.0.3'

Проблема может быть решена путем понижения или обновления обеих версий до аналогичного уровня. Поэтому я понизил базу данных Firebase до

implementation 'com.google.firebase:firebase-core:16.0.1'
implementation 'com.google.firebase:firebase-database:16.0.1'

и это сработало! Все доступные версии можно искать на этом сайте: https://mvnrepository.com/

+3
источник

Для меня эта ошибка появилась после интеграции Crashlytics через Firebase из-за конфликта версий между

implementation 'com.google.firebase:firebase-core:16.0.4'
implementation 'com.google.android.gms:play-services-location:15.0.1'

Я сначала попытался понизить Firebase Core до 15.0.1, но похоже, что такой версии нет, только 15.0.0 и 15.0.2 ! Вместо этого мне пришлось понизить рейтинг до версии 15.0.0, поэтому я закончил с

implementation 'com.google.firebase:firebase-core:15.0.0'
implementation 'com.google.android.gms:play-services-location:15.0.0'

Так что теперь он работает, но я получаю эти раздражающие предупреждения Lint о новых версиях. Этот финал версий - беспорядок.

+2
источник

Вы можете найти библиотеку, которая вытягивает эту зависимость, используя:

$ ./gradlew app:dependencies
+1
источник

Я предполагаю, что следующая ошибка вызвана из-за различных версий зависимостей firebase. Для меня изменение версии всех зависимостей, которые я реализую в моем проекте, до 16.0.1, работало как прелесть.

Для меня ошибка была создана строкой: com.google.firebase:firebase-auth:16.0.2

И я изменил его на: com.google.firebase:firebase-auth:16.0.1

И это сработало. Надеюсь, это поможет.

+1
источник

У меня была ошибка The library com.google.android.gms:play-services-measurement-base is being requested by various other libraries at [[16.0.2,16.0.2]], but resolves to 16.0.0. Disable the plugin and check your dependencies tree using./gradlew :app:dependencies. The library com.google.android.gms:play-services-measurement-base is being requested by various other libraries at [[16.0.2,16.0.2]], but resolves to 16.0.0. Disable the plugin and check your dependencies tree using./gradlew :app:dependencies.

Запуск ./gradlew :app:dependencies покажет, какие зависимости требуют неправильных зависимостей (в квадратных скобках). Для меня проблема исходила из ядра firebase: 16.0.3, как показано ниже. Я исправил это, понизив ядро firebase до 16.0.1

+--- com.google.firebase:firebase-core:16.0.3
|    +--- com.google.firebase:firebase-analytics:16.0.3
|    |    +--- com.google.android.gms:play-services-basement:15.0.1
|    |    |    \--- com.android.support:support-v4:26.1.0 (*)
|    |    +--- com.google.android.gms:play-services-measurement-api:[16.0.1] -> 16.0.1
|    |    |    +--- com.google.android.gms:play-services-ads-identifier:15.0.1
|    |    |    |    \--- com.google.android.gms:play-services-basement:[15.0.1,16.0.0) -> 15.0.1 (*)
|    |    |    +--- com.google.android.gms:play-services-basement:15.0.1 (*)
|    |    |    +--- com.google.android.gms:play-services-measurement-base:[16.0.2] -> 16.0.2
+1
источник

1. Открыть уровень проекта build.gradle

Обновите com.google.gms:google-services версию com.google.gms:google-services до последней версии. Отслеживайте последний выпуск. На момент последнего ответа - 4.1.0.

2. Откройте уровень приложения build.gradle

Обновите зависимость ниже, если вы используете какой-либо. Обратите внимание, что firebase теперь имеет отдельные версии для каждой зависимости.

Используйте последние библиотеки Firebase. Во время ответа последние версии приведены ниже.

Firebase Core                com.google.firebase:firebase-core:16.0.3
Ads                          com.google.firebase:firebase-ads:15.0.1
Analytics                    com.google.firebase:firebase-analytics:16.0.3
App Indexing                 com.google.firebase:firebase-appindexing:16.0.1
Authentication               com.google.firebase:firebase-auth:16.0.3
Cloud Firestore              com.google.firebase:firebase-firestore:17.1.0
Cloud Functions              com.google.firebase:firebase-functions:16.1.0
Cloud Messaging              com.google.firebase:firebase-messaging:17.3.2
Cloud Storage   c            om.google.firebase:firebase-storage:16.0.2
Crash Reporting              com.google.firebase:firebase-crash:16.2.0
Crashlytics                  com.crashlytics.sdk.android:crashlytics:2.9.5
Dynamic Links                com.google.firebase:firebase-dynamic-links:16.1.1
Invites                      com.google.firebase:firebase-invites:16.0.3
In-App Messaging             com.google.firebase:firebase-inappmessaging:17.0.1
In-App Messaging Display     com.google.firebase:firebase-inappmessaging-display:17.0.1
ML Kit: Model Interpreter    com.google.firebase:firebase-ml-model-interpreter:16.2.0
ML Kit: Vision               com.google.firebase:firebase-ml-vision:17.0.0
ML Kit: Image Labeling       com.google.firebase:firebase-ml-vision-image-label-model:15.0.0
Performance Monitoring       com.google.firebase:firebase-perf:16.1.0
Realtime Database            com.google.firebase:firebase-database:16.0.2
Remote Config                com.google.firebase:firebase-config:16.0.0

Синхронизация и сборка...

+1
источник

Я заметил, что в журналах отладки упоминается старая версия firebase-analytics (16.0.0). Добавив явно последнюю версию, исправлена проблема:

implementation "com.google.firebase:firebase-analytics:16.0.3"
+1
источник

Обновите все свои зависимости до последней версии и устраните проблему.

Не нужно добавлять
com.google.gms.googleservices.GoogleServicesPlugin.config.disableVersionCheck = true

Это приведет к сбоям, если вы используете смешанные версии.

+1
источник

В моем случае это решает проблему:

implementation 'com.google.android.gms:play-services-analytics:16.0.1'
+1
источник

В моем случае я заменил мой файл build.gradle на эту строку

implementation 'com.google.firebase:firebase-core:16.0.8'

с

implementation 'com.google.firebase:firebase-core:15.0.0' 

и добавил эту строку

implementation 'com.google.android.gms:play-services-location:15.0.0'

Теперь это хорошо

+1
источник

Я изменил следующие зависимости в моем проекте, чтобы он работал.

build.gradle (приложение):

implementation 'com.google.firebase:firebase-core:16.0.1'

в

implementation 'com.google.firebase:firebase-core:16.0.8'

build.gradle (приложение):

classpath 'com.google.gms:google-services:4.0.1'

в

classpath 'com.google.gms:google-services:4.2.0'

**** Примечание :

Используйте следующую ссылку для обновленного использования библиотек, которые имеют зависимости https://firebase.google.com/docs/android/setup

+1
источник

В моем случае я использую последнюю rnfirebase ниже URL

https://rnfirebase.io/docs/v4.3.x/installation/android

добавьте ниже в android/app/proguard-rules.pro)

-keep class io.invertase.firebase.** { *; }
-dontwarn io.invertase.firebase.**
0
источник

Я столкнулся с этой проблемой и заметил, что в примечаниях к выпуску упоминалось:

Firebase теперь требует, чтобы файл gradle приложения явно указывал com.google.firebase: firebase-core как зависимость для служб Firebase для работы, как ожидалось.

firebase-core зависит от приложения (а также от зависимости от библиотеки) для меня.

0
источник

Если сообщение:

Библиотека com.google.android.gms: play-services-measurement-base запрашивается различными другими библиотеками в [[15.0.4,15.0.4]], но разрешается до 15.0.2. Отключите плагин и проверьте дерево зависимостей с помощью. /gradlew: app: dependencies.

Измените версию всех библиотек игровых сервисов, которые вы используете, на тот, который вам нужен (15.0.2 в этом случае) могут решить проблему.

В моем случае я изменил:

implementation 'com.google.android.gms:play-services-base:+' -> implementation 'com.google.android.gms:play-services-base:15.0.2'
implementation 'com.google.android.gms:play-services-location:+' -> implementation 'com.google.android.gms:play-services-location:15.0.2'
implementation 'com.google.android.gms:play-services-maps:+' -> implementation 'com.google.android.gms:play-services-maps:15.0.2'
implementation 'com.google.android.gms:play-services-auth:+' -> implementation 'com.google.android.gms:play-services-auth:15.0.2'
implementation 'com.google.android.gms:play-services-places:+' -> implementation 'com.google.android.gms:play-services-places:15.0.2'
0
источник

замените "+" на номер версии, он выберет последнюю версию. как это:

implementation 'com.google.firebase:firebase-analytics:+'
0
источник

Решено здесь: Я тоже столкнулся с такой же проблемой при попытке добавить crashlytics в firebase. Обновите последнюю версию зависимостей для com.google.android.gms: play-services и com.google.firebase:....... Он автоматически разрешит проблемы

0
источник

У меня была та же проблема, когда я пытался добавить реализацию базы данных firebase, если бы я прокомментировал эту строку, она работает, поэтому после нескольких попыток я перешел на https://firebase.google.com/docs/android/setup

Там я проверил версии доступных библиотек, и ядро firebase было в 16.0.1 (текущая версия - 16.0.4), поэтому я вручную изменил его, и он работал отлично, сборка и синхронизация были успешными.

0
источник

В моем случае я просто удаляю

implementation "com.google.android.gms:play-services-ads:16.0.0

и добавьте зависимости объявлений Firebase

implementation 'com.google.firebase:firebase-ads:17.1.2'
0
источник

Была такая же проблема. Вы должны удалить двоеточие: после версии в Gradle (это ошибка).

Эти настройки помогли мне:

implementation 'com.google.firebase:firebase-firestore:17.1.5'

Также установите для multiDexEnabled значение true в градле (если вы получили ошибку DexOverflowException):

    android {
        compileSdkVersion 27
..
            multiDexEnabled true
        }
0
источник

просто поместите ниже код:

    implementation 'com.google.firebase:firebase-core:16.0.6'
    implementation 'com.google.firebase:firebase-database:16.0.6'

и восстановить. это работает просто хорошо для меня

0
источник
  • 1
  • 2

Посмотрите другие вопросы по меткам или Задайте вопрос